Skip to content

SheetCam Software Setup Guide

This guide provides step-by-step instructions for installing SheetCam CAM Software. This includes the Avid CNC Mach4 post processor and tool tables for a variety of Hypertherm torches. If you have already installed and licensed SheetCam, skip to Section 3Section 3.

The Pro-Tip video below also shows the SheetCam installation process.

SheetCam Post and Tools Update (September 2021)

For Avid CNC SheetCam Post and Tools v1.7 and newer, also refer to the written instructions below for the most current information.


1. Install SheetCam

SheetCam Install 1


SheetCam Install 2

  • It is recommended to download "SheetCam TNG Stable version".

SheetCam Install 3

  • Navigate to your downloads folder (or the directory you downloaded the installer to) and run the SheetCam TNG installer.

SheetCam Install 6

  • Click "Yes" to begin the installation.

SheetCam Install 7

  • When the installer asks for an install location, it is highly recommended to use the default location.

SheetCam Install 4

  • When you get to the prompt shown above, select the "Create a desktop shortcut" option.

SheetCam Install 5

  • Select the "Run SheetCam TNG" option and finish the SheetCam install.
  • Continue with the setup and license procedure in the next section.

2. Install License File

Software Setup Note

To complete this section you will need your SheetCam license file. This is provided to you by Avid CNC via email after your purchase of SheetCam. It is recommended to save this file to your Downloads folder or Desktop. If you need to purchase a SheetCam license, they are available at Avid CNC{ { config.build.domain.store } }/sheetcam-plasma-cam-software-p-445.html.


SheetCam License 1

  • Select your default language.

SheetCam License 2

  • Use the "SheetCam TNG setup wizard" to setup SheetCam for plasma cutting.

SheetCam License 5

  • Select your preferred units.

SheetCam License 6

  • Select "Jet cutting" machine type for plasma machines.

SheetCam License 7

  • Choose your selections for "Output file units", "Z zero", and "Output folder". The post processor selection will be set in Section 3Section 3.

SheetCam License 3

  • After completing the setup wizard, navigate to "Help > Install license file".

SheetCam License 4

  • Select your license file and click "Open".
  • Close SheetCam before continuing with the next section.

SheetCam License

If you have not already downloaded your SheetCam license, follow the instructions in the email that was sent by Avid CNC after you purchased SheetCam.


3. Install Post Processor and Tool Tables

In this section you will download and install the Avid CNC Mach4 post processor for SheetCam and tool tables for Hypertherm torches. Begin by downloading the installerdownloading the installer for these items. ({ { config.build.domain.support } }/instructions/software/downloads/sheetcam)

SheetCam Usage

If you will not be using the Avid CNC tool tables, you will need to Contact Us ({ { config.build.domain.store } }/contact_us.php) for instructions to add the required SheetCam code snippets and path rules.

Installation Note

Make sure the SheetCam software is closed before continuing with this section.


SheetCam Avid CNC Post and Tools 1

  • Run the installer you just downloaded. The name may vary depending on your download selection.

SheetCam Avid CNC Post and Tools 4

  • Click "Install" to begin the installation.

SheetCam Avid CNC Post and Tools 5

  • Part way through the install, you'll be asked about making changes to your device. Click "Yes" to allow the plasma tools files to be installed correctly.

SheetCam Avid CNC Post and Tools 6

  • Once the finished the installation, open SheetCam.
  • Navigate to "Options > Machine".

SheetCam Avid CNC Post and Tools 7

  • On the "Post Processor" tab, verify "Avid CNC Mach4" is the current post processor.
  • At the bottom of the screen, select "Set custom post options".

SheetCam Avid CNC Post and Tools 8

You will see four different options for customizing the post processor.

  • Distance between references: Distance between pierces where a second probe move (reference) will not take place. The default value of "0" will reference before all pierces.

    On flat and stable (thick) material, increase this value to reduce the number of probe moves and decrease program run time.

  • Reference feed rate: Feed rate for probing reference moves.

  • Touch Off: Select the use of mechanical touch off (post setting of 1) or ohmic touch off (post setting of 0). The material sensor assembly included with the PRO CNC Plasma Kit is configured by default to use ohmic touch off. To use the mechanical touch off, additional changes are required to the material sensor assembly (refer to the Plasma Getting Started GuidePlasma Getting Started Guide).

SheetCam Avid CNC Post and Tools 9

  • To load a tool set, navigate to "File > Open toolset".

Torch Option

For Hypertherm Powermax SYNC torches

SheetCamAvidCNC_ChooseTorch_SYNC

  • Open the folder for your specific Hypertherm plasma system.

Torch Option

For Hypertherm Powermax Duramax torches

SheetCamAvidCNC_ChooseTorch_Duramax

  • Open the folder for your specific Hypertherm plasma system.

Torch Option

For Hypertherm Powermax Duramax torches only

SheetCamAvidCNC_ChooseConsumables

  • Open the folder for the type of consumables you are using with the Duramax torch.

    • Duramax consumables - a consumable stack of retaining cap, shield, nozzle, electrode, and swirl ring.
    • SYNC consumables with cartridge adapter - a single piece cartridge with adapter.

SheetCamAvidCNC_ChooseToolset

  • Select the appropriate toolset for your desired units (English or Metric) and the type of mechanized consumables you are using.

    • Shielded - these are standard mechanized consumables.
    • FineCut - these are specific consumable sets designed for improved fine feature cutting.

SheetCamAvidCNC_ToolsPane

  • After selecting your tool set, the "Tools" pane will show a list of possible tools.
  • Double click on one of the tools.

SheetCamAvidCNC_ToolDetails

  • You will see the tool is pre-populated with the values from the Hypertherm cut charts.
  • Using the AvidCNC Mach4 post processor, these values will be included in your GCode and automatically populated in Mach4 when the program is executed.

4. Using Cut Rules

SheetCamAvidCNC_OpenCutRules

  • To open the cutting rules editor press the Cut Rules button on the left of the Tools menu on the left of the SheetCam application window, or use the drop down menu Tools -> Cutting Rules.

SheetCamAvidCNC_CutRulesDefault_1.7.1

  • The Path Rules window will then be displayed. The default rule set will have been installed by the "AvidCNC for SheetCam" installer. By default all the path rules will be enabled.

  • To disable or enable path rules click the checkbox to the left of the path rule name.


SheetCamAvidCNC_RuleSmallCircles

  • To edit a path rule double click on the name of the rule, this will open the rule options. The rule parameters may be edited and saved by clicking "OK." "Start code" and "End code" are the M codes which will be inserted into the g-code program at the beginning and end of the path rule's effect.

  • Additional types of path rules may be implemented by clicking the "Add rule" button at the bottom of the Path Rules editor window.


Descriptions of the default path rules are below


SheetCamAvidCNC_RuleSmallCircles

SheetCamAvidCNC_RuleExampleSmallCircles

  • Function: disables THC for holes with a diameter under the "Smaller than" value.

  • For most materials the height change across a small circle is too small to really need THC motion, but the tip voltage is unstable during the cut.

  • It is useful to prevent unwanted torch dives caused by unstable tip voltage during short cuts.


SheetCamAvidCNC_RuleSmallShapes

SheetCamAvidCNC_RuleExampleSmallShapes

  • Function: disables THC for closed profiles with an equivalent diameter under the "Smaller than" value.

  • Equivalent Diameter is defined as the diameter of a circle with a circumference equal to the shape's perimeter.

  • For most materials the height change across a small shape is too small to really need THC motion, but the tip voltage is unstable during the cut.

  • It is useful to prevent unwanted torch dives caused by unstable tip voltage during short cuts.


SheetCamAvidCNC_RuleCorners

SheetCamAvidCNC_RuleExampleCorners

  • Function: disables THC for a set distance before and after tight corners.

  • When a cut makes a tight corner it requires the machine to slow down. This causes the plasma arc to grow and the measured tip voltage to increase.

  • This rule prevents unwanted torch dives caused by artificially high tip voltage in tight corners.


SheetCamAvidCNC_RuleLeadIn

SheetCamAvidCNC_RuleExampleLeadInLeadOut

  • Function: disables THC during a leadin.

  • During leadins the tip voltage is typically unstable and above the target.

  • This rule prevents unwanted torch dives caused by artificially high tip voltage.


SheetCamAvidCNC_RuleLeadOut

SheetCamAvidCNC_RuleExampleLeadInLeadOut

  • Function: disables THC during a leadouts.

  • During leadouts the tip voltage is typically unstable and above the target.

  • This rule prevents unwanted torch dives caused by artificially high tip voltage.


SheetCam Cut Rules 4

  • While M codes will not show up in the tool preview any path rules which change the feedrate percentage will highlight the effected operations in blue instead of the normal green.