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General Avid CNC Plasma Information

Plasma Process Overview

1. Safe Height / Retract Height
● At rapid clearance height the machine moves to the XY pierce position and begins the

material touch-off.

2. Material Touch-Off
● The torch moves down until the torch tip makes contact with the material and the ‘Ohmic Probe’

signal reads ‘Active’ in Mach4.
● The Z height is set to Z = 0.

3. Pierce Start
● The torch is moved up to the programmed Pierce Height.
● The torch fires. This starts the programmed Pierce Delay time to allow the arc to fully pierce the

material.

4. Pierce Complete
● When the arc transfers to the material, the torch will send an ‘Arc Okay’ signal triggering the

Delay After Arc OK which inhibits Torch Height Control (THC) motion.
● After the Pierce Delay the arc has fully pierced the material and cutting motion can begin.

5. Cut Start
● The torch is moved to the programmed Cut Height.
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● XY Motion starts.

6. Main Cut
● After the Delay After Arc OK time, THC may be active IF enabled by the g-code AND the Anti

Dive rules allow it.

Ohmic Probe Function
The Ohmic Probe senses the top surface of the material in order to set a local Z axis reference for pierce and
cut heights. The circuit sends the Ohmic Probe Active signal to Mach4 when an electrically conductive path
between the Ohmic Ring (on the torch) and the ground wire (on the material clamp) is completed.

Note: the Ohmic Probe system is NOT involved in Torch Height control. Its only purpose is to set the initial
pierce and cut heights.
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Software User's Guide

SheetCam with Avid CNC Post and Tools
Gcode for Avid CNC Mach4 version 2.4.0+ should be created using version 1.9.0+ of the Avid CNC Mach4
post processor and tools for SheetCam.

Choosing the Correct Installer
The correct installer depends on your torch model.

For Hypertherm Powermax torches with SYNC torches, choose the “Avid CNC Post and Powermax SYNC
Tools for SheetCam” installer.

For Hypertherm Powermax torches with Duramax torches, choose the “Avid CNC Post and Powermax Tools
for SheetCam” installer.

Note: this includes tools for Duramax consumables and SYNC consumables with adapter.

Post Processor Settings
These settings are all found in Options -> Machine -> Post Processor -> Set custom post options.

1. Distance between references: this sets a radius around the most recent probe where subsequent
pierces will start without a probe. Use this to save run time on flat, stable (usually thick) material that
will not have a significant height difference between pierce locations.

2. Reference feed rate: the feedrate during the probe portion of a move. Increasing this from the default
will reduce run time but also reduce the accuracy of the Z positioning.

3. New: Slow Probe Height: this sets a height above the last material Z position that the torch will rapid
down to before starting the slow probe move.
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The first probe in a program will always be full height at slow speed to initially find the material. Using
the Slow Probe Height greatly reduces the run time of programs with many pierces.

4. Touchoff type: sets Ohmic or Mechanical touchoff. Ohmic is recommended.
Note: using Mechanical touchoff requires opening the Ohmic Protection Box and changing a
jumper position.

5. New: End Program Z Height: sets a machine coordinate location to park the Z after a program. This is
used to drive the Z up and reduce water splashing at the end of a cut.
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Toolsets

The toolsets are organized by Torch and Consumable. Each toolset includes a range of materials and
English/Metric thicknesses. It is very important to choose the correct toolset for your torch and consumable.

Within each tool are pre-populated values for all parameters that are tool-specific. A new addition is a
pre-populated AD1 Delay after Arc OK Time.
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This is an Anti Dive setting that inhibits THC motion until X seconds after the arc transfers to the material. This
is a period of very unstable voltage and the duration is related to other material/tool properties.
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Drawing Import
There are settings in Options -> Application Options -> Drawing Import that SheetCam uses to smooth and
simplify vectors when drawings are imported. More detail on the settings is available in Help -> Help Window
-> Menu Items -> Options Menu.

The Avid CNC Post and Tools installer changes some of the settings from default to better match the
capabilities and needs of plasma cutting. Plasma is a relatively rough cutting method that cannot achieve very
fine tolerances. Smoothing the imported vectors will result in smaller file size (⅓ - ½ reduction in gcode lines),
smoother motion. Smoothing will result in small geometry differences but the differences are smaller than the
normal variation in kerf width throughout a cut and the final products of these two files will be indistinguishable.

Setting SheetCam default Avid default

Import link tolerance 0.0004” (0.01mm) 0.0039” (0.1mm)

Max detail reduction error 0.0008” (0.02mm) 0.0157” (0.4mm)

Arc fitting tolerance 0.0039” (0.1mm) 0.0157” (0.4mm)
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Below is an example of SheetCam defaults (left) and Avid CNC defaults (right).

Operation Setup
When a new Jet Cutting operation is created, the Path Rules should be set to Default and the Code Snippet
should be set to “M62P4 (+++THC Allowed, AD2+++)”.

Note: the code snippet may say “Error, M62P4…” initially. This is OK.

The Code Snippet is necessary to ensure that THC is allowed in the operation. The Path Rules will then
allow/inhibit THC for certain features.
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Note that if you don’t want THC active at all during a specific operation within a gcode program, it is important
to also disable the Cut/Path rules for that operation to avoid M62P4 being added automatically on a feature.

Use code snippet Use path ruleset Enable path rules

THC wanted M62P4 (+++THC Allowed, AD2+++) Default All

THC not wanted M63P4 (***THC Inhibited, AD2***) None None

The default path rules are shown below.

● Enabled: On circles/shapes smaller than 0.6in set feed to 70% and disable THC
○ This turns off THC and slows down the cut on small holes/features to prevent dives and improve

the cut accuracy.
● Disabled: On all corners tighter than 60 degrees set feed to 70% and disable THC

○ This is generally redundant and not necessary with the new THC settings.
● Disabled: On leadin disable THC

○ This is generally redundant and not necessary with the new THC settings.
● Enabled: On leadout disable THC

○ This is needed to prevent dives on leadouts that have no material left to cut.
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Mach4 - Feed Rate Override
It is now possible to change the adjustment increment for the Feed Rate Override buttons. This setting is in
Configure -> Avid CNC Mach4 Configuration -> Custom.
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Mach4 Plasma Screen Overview

Help Pop-Ups

Throughout the screen clicking on the “?” icons will bring up brief help windows to describe screen functions.

A: Plasma Settings group
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Torch Settings

1. Z Rapid height: In between plasma cuts the torch will retract to this position IN MACHINE COORDINATES.
The default setting of -1.000in (-25.4mm) means the torch will retract to 1” from the Z home sensor. The Z
Rapid setting should always be (-).

The Set Current button will set the Z Rapid to the current position. Set this for each new program or material.
The rapid position should be above the highest point of the material and above any likely tip-ups.

2. Pierce Warning: This DRO is editable when Mach4 is Disabled. This value is the number of pierces that will
trigger a consumable/pierce life warning to indicate that the consumables are old.

3. Pierce Count: The number of torch fires since the last pierce count reset. Not editable. Reset to 0 with the
Reset button.

4. Pierce Count Warning LED: Turns red when Pierce Warning limit is exceeded.
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5. Volt Offset: Editable DRO and buttons that increment the value by +/- 1V. This sets the Tip Volt zero point
and can be used to trim the voltage for consumable wear or a known offset.

A negative Volt Offset will cause the torch to cut higher. Use this for worn consumables that are cutting
too low.

● Rule of thumb: 1V = 0.003” of electrode wear
A positive Volt Offset will cause the torch to cut lower.

THC and Logging

1. THC toggle: Toggles the Torch Height Control (THC) on and off. Default and recommended state is ON.
2. THC Log toggle: Toggles THC log creation on and off. When ON, THC logs are saved in the

C:\Mach4Hobby\W9_HC folder
3. Mark Log File: adds a numbered mark in the THC log file at the current timestamp
4. Log file mark number
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THC Settings

1. Material Profile: Use the arrows to choose the profile that best matches the Z height fluctuations of the
material. Changes preset values for THC speed and Anti-Dive settings.

FLAT will be used in the vast majority of situations.

2. Up Sensitivity: Default of 100 uses the recommended precalculated THC settings. Increasing will increase
the Z axis response speed in the UP direction. Decreasing will slow Z speed in the UP direction. This
override setting is specific to a Material Profile and will be saved for FLAT, MODERATE, SEVERE.

3. Down Sensitivity: Default of 100 uses the recommended precalculated THC settings. Increasing will
increase the Z axis response speed in the DOWN direction. Decreasing will slow Z speed in the DOWN
direction. This override setting is specific to a Material Profile and will be saved for FLAT, MODERATE,
SEVERE.
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B: Plasma Monitors group

1. Torch: shows if the torch is commanded ON or OFF
2. THC Motion: shows if THC motion is INHIBITED, UP, or DOWN.

Note: INHIBITED does not mean that THC is turned off or is not working. It means that for some reason
THC motion is currently inhibited which could be because of an inhibit in the gcode or an Anti Dive
rule.

3. Consumable LED: turns red if the Pierce Warning limit is exceeded.
4. Consumable Life: shows if the number of pierces since last reset is GOOD or the consumables should be

changed (REPLACE).
5. Hardware Comms: shows if Mach4 has established communication with the WarpRunner/TMC3in1 THC

controller. States are NONE, ACTIVE, and UPDATING.
● ACTIVE is required to start gcode
● UPDATING means the WarpRunner/TMC3in1 is updating its firmware. This is common after

updating Mach4 with new plugin versions.
6. Actual: displays the actual Tip Volts measured by the plasma power supply and WarpRunner/TMC3in1.

The Volt Offset is also applied.
7. Target: the Target Tip Volts are read from properly prepared gcode once the program is started. The target

can be adjusted up and down during a program using the arrows.
8. Torch Manual Trigger: turns the torch ON or OFF. Caution: this will fire the torch with no additional

warning so make sure to use proper PPE
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Typical Program Workflow
Typical operation will look something like this:

1. Home machine and set work XY zero
2. Set Z Rapid Height
3. Check consumable state
4. Check THC state
5. Verify THC settings
6. Cycle Start gcode

Load Gcode

After loading new gcode the tab focus will switch to Plasma Settings to continue setting up for the
program.

Set Z Rapid Height

Jog the torch to a safe Z height for the material and tip ups. Set Current to set the Z Rapid height.
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Check Consumable State

Make sure the current consumables are within their useful life.

Check THC state

In most cases this should be ON.

Verify THC Settings

Make sure the material profile and sensitivity settings match the program’s needs.
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Torch Height Control (THC)

Operating Theory
The purpose of a THC system is to maintain a consistent torch-to-material offset across a workpiece. This
allows for the best cut quality on materials that vary in height due to warping or inherent waviness.

Most THC systems use Arc Voltage (Tip Volts) as an indirect measurement of height. The arc voltage is
measured between the Electrode (in the consumable stack) and the workpiece. The plasma arc voltage
between the electrode (-) and workpiece (+) is governed by the equation

V = I x R or Voltage = Current x Resistance

The arc current is constant but the resistance increases with increasing arc length. This means the arc voltage
increases as the arc lengthens and can be used as an indirect measurement of torch-to-material offset.

A THC system will move the Z axis / torch up and down as it attempts to bring the Actual Tip Volts closer to the
Target Tip Volts.

Because it is an indirect measurement, Tip Volts and actual torch height will not always directly correlate.
Some of these situations and the likely results in tip voltage:

● Leadin/leadout - the voltage is unstable when the XY velocity changes significantly.
● Tight corners - the voltage typically increases as the XY motion slows around a corner.
● Small holes/shapes - the voltage will increase as XY motion slows
● Pre-cut material (voids) - the voltage will increase rapidly as the torch-material distance gets very

large because there is no material directly under the torch.

All of these situations can lead to unintended THC motion. In most cases this will be an unwanted dive towards
the material. This unwanted motion can be prevented in some cases with Anti Dive settings and in all cases
can be reduced with correct THC tuning for the material.
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Avid CNC Mach4 THC Tuning
Material Profile

The Z axis speed required for the torch to successfully follow material height variations is dependent on the
severity of the slope and the XY feedrate (set in SheetCam). In the two exaggerated illustrations below, the
torch needs to follow the orange path. The XY feedrate remains constant but the slope increases so the
material on the right will need a greater Z axis speed to follow the material.

Because most disruptive events (corners, holes, etc) during a cut lead to an increase in tip voltage and a likely
dive, it is useful to only allow enough Z axis speed to follow the likely material curve and correct for delayed
response. The Profile settings of FLAT, MODERATE, SEVERE allow increasingly faster Z motion to correct for
voltage errors. Each setting also adjusts some Anti Dive settings for best performance.

The FLAT material profile should be used in most cases. This is intended for material that is nominally flat but
may have some warping or may warp during cutting. A 5% slope (0.6in/12in) can easily be handled by this
profile.

MODERATE and SEVERE should only be used for significant material slopes or severely warping thin
material. In order to perform on sloped material these settings allow faster Z motion and have looser Anti Dive
settings that will not catch as many voltage spikes. This can lead to torch crashes on flatter material or very
complex cuts on sloped material.
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Fine Tuning - Up and Down Sensitivity

Within each Profile setting the Z axis response speed for Up and Down movements can be adjusted
independently. This acts as a percentage override to the pre-calculated values. 100 is the default and the
range is 10-200.

If the torch fails to closely track the material Up or Down, use the Plus arrow to increase the Up or Down
setting(s).

If the torch moves moves up or down too much (diving/crashing or excessive height), use the Minus arrow to
decrease the Up or Down setting(s) appropriately.

These settings are specific to each Profile. They can be adjusted on-the-fly during a cut.
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Additional THC Settings
Several other settings are available but rarely needed.

Each material Profile has default Anti Dive settings that are intended to only allow the Z motion necessary to
track the material. In general steeper material slopes require Anti Dive settings that allow motion more often.

The example above is a corner on sloped material. The torch path is shown in orange, following the blue
profile. The upper image shows that Velocity Anti-Dive may inhibit THC motion around the corner because
the tip volts are likely to spike. But as the torch starts to move past the corner the material will drop away
before the Z axis is allowed to respond. Depending on the Anti Dive settings this could result in poor quality or
a failed cut.
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Velocity Anti-Dive Thresholds

This setting is in the Configure -> Avid CNC Mach4 Configuration menu. It sets a threshold at the given
percentage of programmed XY feedrate. If the actual feedrate drops below the threshold (due to acceleration
limits in corners and small arcs), THC motion is inhibited until the feedrate recovers.

If the torch is frequently diving in low speed situations but otherwise tracking the material properly, increasing
the Velocity Anti-Dive Threshold could help prevent the dives.

If the torch is failing to track the material during or after low speed situations, decreasing the Velocity Anti-Dive
Threshold could help to allow more motion.
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Voltage Anti-Dive Thresholds

This setting is in the Configure -> Avid CNC Mach4 Configuration menu. It sets a threshold at the given
percentage above the Average Tip Volts during a cut. If the Actual (or “instantaneous”) tip voltage exceeds the
threshold, THC motion is inhibited until the actual voltage drops.

The image above shows the Actual voltage (red) spike above the Average (blue) and threshold (orange). In
this case THC motion would be inhibited during the spike.

If the torch is frequently diving when crossing voids or other irregularities, decreasing the Voltage Anti-Dive
Threshold could help prevent the motion.
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If the torch fails to begin following changes in material slope, increasing the Voltage Anti-Dive Threshold could
help allow motion sooner. This would look like the image below where the torch does not follow the intended
path (dashed orange) and has to quickly recover.
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Advanced Manual THC Anti-Dive Settings

If necessary or desired, the Avid CNC THC parameter calculations can be disabled. Doing so will disable all
feedrate and profile based Z axis response calculations. This should only be done by users that have an
understanding of each Anti-Dive setting, including the Linear Response Band.

This will hide the Profile and Sensitivity settings and expose the THC Anti-Dive tab
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Getting Help

If you have performance issues that cannot be resolved with the available settings, please contact us with as
many of the following files as possible:

1. SheetCam project file (.job extension)
2. G-code file (.tap or other text file equivalent)
3. THC log file (.thc extension). These will be saved by default in C:\Mach4Hobby\W9_HC
4. Mach4 log file (.log extension), saved wherever you choose.

Recording a THC Log

1. Make sure the THC Log toggle is ON.
2. Run the program that is experiencing issues.
3. Copy the log file. Log files are saved in C:\Mach4Hobby\W9_HC with a timestamp filename and a

“.thc” extension.

Recording a Mach4 Log

https://www.avidcnc.com/support/instructions/software/mach4UsersGuide/#record-mach4-diagnostic-log

Find the Diagnostic menu at the top of Mach4 and select Logging. This will pop up the window below. Use the
Play button to start logging before hitting Cycle Start, and save the log file after the relevant program is finished
to minimize the log file size.
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