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SheetCam Software Setup & Users Guide

This guide provides step-by-step instructions for installing SheetCam and setting up the Avid CNC Mach4 post processor
and tool tables for a variety of Hypertherm torches. If you have already installed and licensed SheetCam, skip to Section 3.

The Pro-Tip video below also shows the SheetCam installation process.

For Avid CNC SheetCam Post and Tools v1.7 and newer, refer to the written instructions below for the most current
information.

1. Install SheetCam

Navigate to https://www.sheetcam.com/downloads

SheetCam Post and Tools Update (September 2021)

https://www.sheetcam.com/downloads
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It is recommended to download "SheetCam TNG Stable version".

Navigate to your downloads folder (or the directory you downloaded the installer to) and run the SheetCam TNG
installer.
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Click "Yes" to begin the installation.
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When the installer asks for an install location, it is highly recommended to use the default location.
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When you get to the prompt shown above, select the "Create a desktop shortcut" option.
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Select the "Run SheetCam TNG" option and finish the SheetCam install.

Continue with the setup and license procedure in the next section.
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2. Install License File

To complete this section you will need your SheetCam license file. This is provided to you by Avid CNC via email after your
purchase of SheetCam. It is recommended to save this file to your Downloads folder or Desktop. If you need to purchase a
SheetCam license, they are available at { { config.build.domain.store } }/sheetcam-plasma-cam-software-p-445.html.

Select your default language.

Software Setup Note
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Use the "SheetCam TNG setup wizard" to setup SheetCam for plasma cutting.
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Select your preferred units.
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Select "Jet cutting" machine type for plasma machines.
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Choose your selections for "Output file units", "Z zero", and "Output folder". The post processor selection will be
set in Section 3.
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After completing the setup wizard, navigate to "Help > Install license file".
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Select your license file and click "Open".

Close SheetCam before continuing with the next section.

If you have not already downloaded your SheetCam license, follow the instructions in the email that was sent by Avid CNC
after you purchased SheetCam.

SheetCam License
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3. Install Post Processor and Tool Tables
In this section you will download and install the Avid CNC Mach4 post processor for SheetCam and tool tables for
Hypertherm torches. Begin by downloading the installer for these items. ({ { config.build.domain.support }
}/instructions/software/downloads/sheetcam)

If you will not be using the Avid CNC tool tables, you will need to Contact Us ({ { config.build.domain.store }
}/contact_us.php) for instructions to add the required SheetCam code snippets and path rules.

Make sure the SheetCam software is closed before continuing with this section.

Run the installer you just downloaded. The name may vary depending on your download selection.

SheetCam Usage

Installation Note
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Click "Install" to begin the installation.

Part way through the install, you'll be asked about making changes to your device. Click "Yes" to allow the plasma
tools files to be installed correctly.

Once installation has finished, continue to the next section.
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4. Post Processor Setup
In this section you will configure your post processor setting for your machine. This is a critical step to ensuring programs
created in SheetCam work correctly.

Post Processor Selection

Open SheetCam.

Navigate to "Options > Machine".
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On the "Post Processor" tab, verify "Avid CNC Mach4" is the current post processor.

At the bottom of the screen, select "Set custom post options".
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Post Processor Settings

1. Distance between references

Sets a radius around the most recent probe where subsequent pierces will start without a probe. This value can be
increased to reduce program run time on flat, stable (usually thick) material that will not have a significant height
difference between pierce locations.

2. Reference feed rate

Sets the feedrate during the probe portion of a move. Increasing this from the default will reduce run time but also
reduce the accuracy of the Z positioning.

3. Slow Probe Height

Sets a height above the last material Z position that the torch will rapid down to before starting the slow probe move.

The first probe in a program will always be full height at slow speed to initially find the material. Using the Slow Probe
Height greatly reduces the run time of programs with many pierces.
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4. Touchoff type

This dialog sets the touchoff type - Ohmic or Mechanical. For general operation, Ohmic touchoff is strongly
recommended.

Using Mechanical touchoff requires opening the Ohmic Protection Box and changing a jumper position.

For more information please refer to the Plasma Getting Started Guide.

5. End Program Z Height

Sets a machine coordinate location to park the Z after a program. This is used to drive the Z up and reduce water
splashing at the end of a cut.

Note

file:///C:/avidcnc/documentation/Software/site/sheetcamSoftwareSetup/%7B%20%7Bconfig.build.domain.support%7D%20%7D/instructions/plasma/gettingStartedGuide/#310
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5. Choosing a Toolset

To load a tool set, navigate to "File > Open toolset".
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For Hypertherm Powermax SYNC torches

Open the folder for your specific Hypertherm plasma system.

For Hypertherm Powermax Duramax torches

Open the folder for your specific Hypertherm plasma system.

Torch Option

Torch Option
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For Hypertherm Powermax Duramax torches only

Open the folder for the type of consumables you are using with the Duramax torch.

Duramax consumables - a consumable stack of retaining cap, shield, nozzle, electrode, and swirl ring.

SYNC consumables with cartridge adapter - a single piece cartridge with adapter.

Select the appropriate toolset for your desired units (English or Metric) and the type of mechanized consumables you
are using.

Shielded - these are standard mechanized consumables.

FineCut - these are specific consumable sets designed for improved fine feature cutting.

Torch Option
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After selecting your tool set, the "Tools" pane will show a list of possible tools.

Double click on one of the tools.
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You will see the tool is pre-populated with the values from the Hypertherm cut charts and Avid CNC calculations.

Using the AvidCNC Mach4 post processor, these values will be included in your GCode and automatically populated in
Mach4 when the program is executed.
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6. SheetCam Drawing Import Settings
There are settings in Options -> Application Options -> Drawing Import that SheetCam uses to smooth and simplify
vectors when drawings are imported. More detail on the settings is available in Help -> Help Window -> Menu Items ->
Options Menu.

The Avid CNC Post and Tools installer changes some of the settings from default to better match the capabilities and
needs of plasma cutting. Plasma is a relatively rough cutting method that cannot achieve very fine tolerances. Smoothing
the imported vectors will result in smaller file size (1/3 - 1/2 reduction in gcode lines) and smoother motion. Smoothing will
result in geometry differences that are smaller than the normal variation in kerf width throughout a cut. The final products of
these two files will be indistinguishable.

Setting SheetCam Default Avid Default

Import link tolerance 0.0004" (0.01mm) 0.0039" (0.1mm)

Max detail reduction error 0.0008" (0.02mm) 0.0157" (0.4mm)

Arc fitting tolerance 0.0039" (0.1mm) 0.0157" (0.4mm)

Below is an example of SheetCam defaults (left) and Avid CNC defaults (right).
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7. Operation Setup
When a new Jet Cutting operation is created, the Path Rules should be set to Default and the Code Snippet should be set
to "M62P4 (+++THC Allowed, AD2+++)".

The code snippet may say "Error, M62P4..." initially. This is OK and can be ignored for the first instance.

The Code Snippet is necessary to ensure that THC is allowed in the operation. The Path Rules will then allow/inhibit THC
for certain features.

Note that if you don't want THC active at all during a specific operation within a gcode program, it is important to also
disable the Cut/Path rules for that operation to avoid M62P4 being added automatically on a feature.

Use Code Snippet Use Path Ruleset Enabled Path Rules

THC wanted M62P4 (+++THC Allowed, AD2+++) Default Yes

THC not wanted M63P4 (***THC Inhibited, AD2***) None None

Note
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8. Using Cut Rules
Path or Cut Rules in SheetCam serve as instructions for the post processor to modify the G-Code output for specific
toolpath features. The most common uses of Path Rules are preventing dives by inhibiting THC or improving cut quality by
locally reducing the feedrate.

To open the cutting rules editor press the Cut Rules button on the left of the Tools menu on the left of the SheetCam
application window, or use the drop down menu Tools -> Cutting Rules.

The Path Rules window will then be displayed. The default rule set will have been installed by the "AvidCNC for
SheetCam" installer.

To disable or enable path rules click the checkbox to the left of the path rule name.
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To edit a path rule double click on the name of the rule, this will open the rule options. The rule parameters may be
edited and saved by clicking "OK." "Start code" and "End code" are the M codes which will be inserted into the g-code
program at the beginning and end of the path rule's effect.

Additional types of path rules may be implemented by clicking the "Add rule" button at the bottom of the Path Rules
editor window.
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Descriptions of the Avid CNC default path rules are below

Enabled by default.

Function: disables THC for holes with a diameter under the "Smaller than" value. Reduces the feed rate to the set
percentage.

For most materials the height change across a small circle is too small to really need THC motion, but the tip voltage is
unstable during the cut.

It is useful to prevent unwanted torch dives caused by unstable tip voltage during short cuts.

Reducing the feedrate for small circles can help reduce the bevel of the cut.
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Enabled by default.

Function: disables THC for closed profiles with an equivalent diameter under the "Smaller than" value. Reduces the
feed rate to the set percentage.

Equivalent Diameter is defined as the diameter of a circle with a circumference equal to the shape's perimeter.

For most materials the height change across a small shape is too small to really need THC motion, but the tip voltage
is unstable during the cut.

It is useful to prevent unwanted torch dives caused by unstable tip voltage during short cuts.

Reducing the feedrate for small shapes can help reduce the bevel of the cut.
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Disabled by default.

Function: disables THC for a set distance before and after tight corners. Reduces the feed rate to the set percentage.

When a cut makes a tight corner it requires the machine to slow down. This causes the plasma arc to grow and the
measured tip voltage to increase.

This rule can prevent unwanted torch dives caused by artificially high tip voltage in tight corners.

In most cases, this rule is not needed and can hinder THC's ability to track the material properly.
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Disabled by default.

Function: disables THC during lead-ins.

During lead-ins the tip voltage is typically unstable and above the target.

This rule can prevent unwanted torch dives caused by artificially high tip voltage.

In most cases this rule is not needed due to redundancy with other THC Anti Dive settings.
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Enabled by default.

Function: disables THC during lead-outs.

During leadouts the tip voltage is typically unstable and above the target.

This rule can prevent unwanted torch dives caused by artificially high tip voltage.
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While M codes will not show up in the tool preview, any path rules which change the feedrate percentage will highlight
the effected operations in blue instead of the normal green.
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